You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
 
 
 
 
 
η (eta) a224a1d9fb implement out-of-order insertion into the conversation view 1 year ago
.gitlab/issue_templates add issue templates 4 years ago
data Read categories from desktop file 1 year ago
flatpak Flatpak: Update dependencies 1 year ago
gajim implement out-of-order insertion into the conversation view 1 year ago
mac MacOS: remove debug line from makebundle.py 2 years ago
po updated translations 1 year ago
scripts/dev there is no more core plugins. see [765180d1] 1 year ago
test Use nbxmpp.namespaces 1 year ago
win Windows: Fix mixed indentation 1 year ago
.gitignore Quite hacky replacement of the HtmlTextView with some listboxes 'n' stuff 1 year ago
.gitlab-ci.yml Replace deprecated test command 1 year ago
AUTHORS Add dummy AUTHORS file 4 years ago
CONTRIBUTING.md Update CONTRIBUTING.md 2 years ago
COPYING next release will be GPL v3. fixes #3290 14 years ago
ChangeLog Update ChangeLog 1 year ago
MANIFEST.in Package test, but don't install it 4 years ago
README.md Require python 3.7 1 year ago
appveyor.yml CI: Enable appveyor FTP upload 1 year ago
launch-history-manager.py HistoryManager: Init configpaths only in standalone mode 3 years ago
launch.py Use setuptools' automatic script creation 3 years ago
mypy.ini Update mypy.ini 1 year ago
pylintrc Update .pylintrc 1 year ago
setup.cfg Require python 3.7 1 year ago
setup.py Require python 3.7 1 year ago

README.md

Welcome to Gajim

Runtime Requirements

  • python3.7 or higher
  • python3-gi
  • python3-gi-cairo
  • gir1.2-gtk-3.0 (>=3.22)
  • python3-nbxmpp (>=0.9.94)
  • python3-openssl (>=16.2)
  • python3-css-parser
  • python3-keyring
  • python3-precis-i18n
  • gir1.2-soup-2.4

Optional Runtime Requirements

  • python3-pil (pillow) for support of webp avatars
  • gir1.2-avahi-0.6 for zeroconf on Linux or pybonjour on Windows/macOS
  • gir1.2-gspell-1 and hunspell-LANG where lang is your locale eg. en, fr etc
  • gir1.2-secret-1 for GNOME Keyring or KDE support as password storage
  • D-Bus running to have gajim-remote working
  • gir1.2-farstream-0.2, gir1.2-gstreamer-1.0 and gir1.2-gst-plugins-base-1.0 for audio and video calls
  • gir1.2-gupnpigd-1.0 for better NAT traversing
  • gir1.2-networkmanager-1.0 for network lose detection
  • gir1.2-geoclue-2.0 for sharing your location
  • gir1.2-gsound-1.0 for sound on Linux

Compile-time Requirements

  • python3-setuptools
  • gettext

Installation Procedure

Packages

Flatpak

see README

Snapshots

Linux

pip install .

Mac

see Wiki

Developing

For developing you don't have to install Gajim.

After installing all dependencies execute

./launch.py

Windows

see README

Miscellaneous

Debugging

Execute gajim with --verbose

That is all, enjoy!

(C) 2003-2020 The Gajim Team https://gajim.org

We use original art and parts of sounds and other art from Psi, Gossip, Gnomebaker, Gaim and some icons from various gnome-icons (mostly Dropline Etiquette) we found at art.gnome.org. If you think we're violating a license please inform us. Thank you.